meta http-equiv='X-UA-Compatible' content='IE=7' 意思是将IE8用IE7进行渲染

【字号: 日期:2024-06-10浏览:28作者:雯心
X-UA-Compatible是针对ie8新加的一个设置,对于ie8之外的浏览器是不识别的,这个区别与content=IE=7在无论页面是否包含!DOCTYPE指令,都像是使用了 Windows Internet Explorer 7的标准模式。而content=IE=EmulateIE7模式遵循!DOCTYPE指令。对于多数网站来说,它是首选的兼容性模式。 目前IE8尚在测试版中,所以为了避免制作出的页面在IE8下面出现错误,建议直接将IE8使用IE7进行渲染。也就是直接在页面的header的meta标签中加入如下代码: meta http-equiv=X-UA-Compatible content=IE=7 / 这样我们才能使得页面在IE8里面表现正常! 浏览器市场份额的激烈竞争,给网页设计开发人员带来了兼容性设计的麻烦。单单 IE 浏览器就有好几个主流版本,IE6、IE7、IE8 等等。当然使用诸如 IETester,多版本 IE 共存解决方案之类的第三方集成工具,可以方便代码调试。但我们总需要找寻一种更为省时省力的方法。 X-UA-Compatible 是针对 IE8 版本的一个特殊文件头标记,用于为 IE8 指定不同的页面渲染模式。由于当下 IE6 和 IE7 使用率依然较高,综合考虑,启用 IE8 版本的 X-UA-Compatible 兼容模式显得相当重要。 各种兼容模式代码示例如下: meta http-equiv=X-UA-Compatible content=IE=5 / 像是使用了 Windows Internet Explorer 7 的 Quirks 模式,这与 Windows Internet Explorer 5 显示内容的方式很相似。 meta http-equiv=X-UA-Compatible content=IE=7 / 无论页面是否包含 !DOCTYPE 指令,均使用 Windows Internet Explorer 7 的标准渲染模式。 meta http-equiv=X-UA-Compatible content=IE=8 / 开启 IE8 的标准渲染模式,但由于本身 X-UA-Compatible 文件头仅支持 IE8 以上版本,因此等同于冗余代码。 meta http-equiv=X-UA-Compatible content=edge / Edge 模式通知 Windows Internet Explorer 以最高级别的可用模式显示内容,这实际上破坏了锁定模式。 meta http-equiv=X-UA-Compatible content=IE=EmulateIE7 / EmulateIE7 模式通知 Windows Internet Explorer 使用 !DOCTYPE 指令确定如何呈现内容。标准模式指令以Windows Internet Explorer 7 标准模式显示,而 Quirks 模式指令以 IE5 模式显示。与 IE7 模式不同,EmulateIE7 模式遵循 !DOCTYPE 指令。对于多数网站来说,它是首选的兼容性模式。 在现阶段,IE8 版本推向市场没有多久,份额不高。因此,考虑兼容旧版本的模式值得推荐。现在推荐用:复制代码代码如下: ![if lte IE 8] meta http-equiv=x-ua-compatible content=ie=7 / ![endif] ![if IE 9] meta http-equiv=x-ua-compatible content=ie=9 / ![endif]
相关文章: